We wanted to give you advance notice of a key change to Koken's server requirements that will take effect at the beginning of next year. As of January 1st, 2015, we will no longer provide support for PHP 5.2.

Since the first private beta release (nearly 2 years ago now), we've provided support for any web host running PHP 5.2 or greater. While this allowed us to reach a broader audience, it has also hampered support efforts as time has gone by. PHP 5.2 was last updated in January of 2011, and no longer receives bugfixes or security updates. Furthermore, newer versions of PHP are both faster and more efficient, resulting in a better overall experience for Koken users.

Beginning in Koken 0.17.4 (which was released today), users who are still using PHP 5.2 will be notified by a warning modal and a message in Settings > System when they are signed in to the administrative console. If you are running PHP 5.2, we suggest you contact your host sooner rather than later to see what options they have for upgrading PHP. They may already have a way to update to a later version. Koken supports all the maintained, stable versions of PHP, which currently includes PHP 5.3, 5.4, 5.5, and the newly released 5.6.

If you have not updated to PHP 5.3 or higher by January 1st, your installation will continue to work. However you will no longer be able to update Koken to new versions or receive technical support regarding server issues until PHP is upgraded. 

For more information on this change, see our dedicated help article on the PHP 5.2 phaseoutIf you have any questions, please contact us and we'll be glad to help.